Replace URL By Name - Amazon Links werden nicht erkannt?

  • Mir ist aufgefallen, dass bei Amazon Links der Name nicht erkannt wird. Installiert habe ich die Version 1.0.0 pl 1 des Plugins.


    Egal, welche Schreibweise ich nehme, der Name des Artikels (so heißt auch das Fenster oder der Tab) wird nicht erkannt.

    Code
    1. https://www.amazon.de/gp/product/B01J41GQXK/
    2. https://www.amazon.de/Lego-75163-LEGO-Star-Wars/dp/B01J41KZZ0/ref=pd_sim_21_75?_encoding=UTF8&psc=1&refRID=QNB8NTQGEK9Z2AGTNN0Y
    3. https://www.amazon.de/gp/product/B01MDJPR86/ref=s9u_wsim_gw_i3?ie=UTF8&pd_rd_i=B01MDJPR86&pd_rd_r=M2232RHRNC27Y711MFW1&pd_rd_w=jhTR6&pd_rd_wg=FE6X8&pf_rd_m=A3JWKAKR8XB7XF&pf_rd_s=&pf_rd_r=F179XQYP33QZV86RVF5K&pf_rd_t=36701&pf_rd_p=a604e9f7-44cb-43ba-9116-40fbc776b12b&pf_rd_i=desktop
    4. https://www.amazon.de/Casio-FX-991DE-wissenschaftlicher-ClassWiz-nat%C3%BCrlichem/dp/B00VB2ISDM/ref=br_asw_pdt-4?pf_rd_m=A3JWKAKR8XB7XF&pf_rd_s=&pf_rd_r=F179XQYP33QZV86RVF5K&pf_rd_t=36701&pf_rd_p=d65fc394-c91c-4bcd-a581-f31f61f48e5f&pf_rd_i=desktop


    Aus diesen Links wird dann folgendes Ergebnis:



    Hier wäre ein passendes Test-Thema zu finden:
    Links zu Amazon - Testlabor - CompiWare - Your Way to your Computer


    Wäre es möglich, das Plugin so anzupassen, dass auch Namen von Amazon Links angezeigt werden?

    Ich brauche keine Signatur! :)

  • Das Problem ist hier, dass die Erweiterung nur die ersten X Kilobyte einer Seite ausliest und daraus den Titel zieht. Bei Amazon steht der Titel verhältnismäßig weit unten, sodass es der Erweiterung aufgrund der festgelegten Einschränkung nicht möglich ist, den Titel zu beziehen, wodurch das Fallback greift.


    Bis zum nächsten Update reicht es, in der Datei {wcf}/lib/system/event/listener/ReplaceURLByNameListener.class.php nach 51200 zu suchen und dort eine 0 anzuhängen.

  • Ich habe die Datei im Verzeichnis /lib/system/event/listener/ gefunden und laut Anweisung abgeändert. Danach habe ich den Cache geleert, aber trotzdem zeigt das keine Änderung. Die Namen werden noch immer nicht angezeigt... :(


    Siehe: Links zu Amazon - Testlabor - CompiWare - Your Way to your Computer


    Habe ich etwas übersehen?


    EDIT: Jetzt werden gar keine Links mehr erkannt und in Namen umgewandelt... :(

    Ich brauche keine Signatur! :)

    Einmal editiert, zuletzt von PoooMukkel ()

  • Oh my god... Lesen sollte man schon richtig können... :D


    nach 51200 zu suchen und dort eine 0 anzuhängen

    Ich hatte die 51200 durch die 0 ersetzt und sie nicht angehangen. Jetzt funktioniert es natürlich auch bei mir... :) :thumbsup:



    Man man man... Hoffentlich wird das nicht noch schlimmer im Alter... :D

    Ich brauche keine Signatur! :)