Image Hotlink Control mit 4.1.19

  • Hallo zusammen,


    ich habe das Image Hotlink Control Tool testweise mit der aktuellen Woltlab-Version installiert. Kann es sein, dass das mit der neuen Einstellung "Bilder von externen Seiten erlauben" nicht mehr funktioniert? Oder habe ich die Funktion falsch verstanden? Oder muss ich noch woanders etwas einstellen? Ich hatte die Version vor dem PlugIn installiert. Mein Ziel ist folgendes:


    Ich nutze den Whitelist-Modus und dort sollen nur Seiten mit https:// erlaubt sein. Wenn ich nun eigentlich externe Bilder zulasse, aber die Whitelist anhake, wo noch nichts drin steht, müssten dann nicht alle externen Bilder verboten sein? Ich konnte aber ein externes Bild mit BBCodes von eine Bildchenplattform einfügen. Das ist in einen [img] Link eingebettet in ein [url], wie das dort häufig der Fall ist.




    Also, ich hätte gedacht, dass ich nun kein Bild einfügen kann. Das geht aber noch.


    Alles, was schon im Forum gepostet wurde, bleibt auch so, richtig?

  • Muss später mal schauen, ob das Plugin in seiner Form überhaupt noch mit neueren Versionen des WCF 2.1 kompatibel ist.

  • Das wäre Super weil nicht jeder externe Anbieter Daten abfängt oder Sie verarbeitet

  • Servus,


    Sascha

    hattest Du vor lauter DSGVO schon Zeit um mal in das Thema reinzusehen?


    Ich wollte den Spritmonitor für die Signatur freigeben

  • Bisher war noch keine Zeit. Vielleicht schaffe ich das heute Nacht.

  • Wenn ich nun eigentlich externe Bilder zulasse, aber die Whitelist anhake, wo noch nichts drin steht, müssten dann nicht alle externen Bilder verboten sein? Ich konnte aber ein externes Bild mit BBCodes von eine Bildchenplattform einfügen.


    Das funktionierte in meinen Tests problemlos:



    Ich nehme allerdings an, dass dir nicht bewusst ist, dass es bei den Benutzergruppen im Bereich Nachrichten die Option Kann Einstellungen zur Bilder-Einbindung übergehen gibt, welche für Administratoren generell aktiviert ist und es dir daher möglich war, die von dir festgelegten Restriktionen zu umgehen.


    Ich nutze den Whitelist-Modus und dort sollen nur Seiten mit https:// erlaubt sein.


    Bisher war das nicht vorgesehen. Wird aber mit der nächsten Version möglich sein.

  • Ah, ok, das erklärt vieles. Danke!


    O.k. also nutze ich die neue Woltlab Einstellung nicht und lasse externe Bilder zu, dann habe ich das Problem, dass alle alten Bilder noch immer angezeigt werden, weil dies auf die Historie nicht wirkt. Das würde mir also auch für diesen Zweck leider nicht helfen. Schade.


    Nutzte ich aber die Woltlabfunktion und lasse externe Bilder nicht anzeigen, dann sind es Links und ich habe kein Problem mit nicht https:// Seiten.


    Das ist alles irgendwie noch keine wirkliche Lösung. Schade, aber danke für die Erklärung. Wenns nichts anderes gibt, bleibt mir nichts als das so zu machen.

  • Ich denke, innerhalb der nächsten Stunde bin ich damit durch. Da es allerdings ein paar Struktur-Änderungen gab, wird eine Neuinstallation notwendig sein.

  • Guten Morgen,


    war doch eine etwas längere Stunde, allerdings sind mir noch ein paar Dinge eingefallen, die es zu beachten galt. Die neue Version ist dafür nun fertig und kann ab sofort herunter geladen werden:


    Herunterladen (Version 1.1.0 pl 3) (Kostenlos)

    Image Hotlink Control WCF 2.0 & WCF 2.1

    Kontrollieren Sie die Einbindung externer Bilder.



    An den Optionen hat sich weitestgehend nichts geändert. Die größte Änderung gegenüber der Version aus 2016 ist die Behandlung bereits eingebundener Bilder. Wurden in der Vergangenheit bereits Bilder eingebunden, deren Einbindung bedingt durch die gesetzten Optionen nicht (mehr) möglich sein sollte, werden diese nun auch nicht mehr angezeigt. Ferner kann man nun gestatten, externe Bilder einbinden zu können, wenn die Einbindung via SSL erfolgte. Bisher war das nur für festgelegte Hosts möglich, ab sofort funktioniert das für sämtliche Hosts in dieser Kombination:


    Whitelist -> aus

    Hosts -> *|allowHTTPS


    Möchte man dennoch einige Hosts generell ausschließen (unabhängig davon, ob die Einbindung via SSL erfolgt, oder nicht), muss der Eintrag *|allowHTTPS am Ende der Liste stehen.


    Der interne Image-Proxy wurde generalüberholt und es gab kleinere Fehlerbehebungen und Optimierungen.


    Eine Neuinstallation ist notwendig, da es teilweise Umstrukturierungen und Umbenennungen gab.


    Viel Spaß damit :)

  • Super Sascha - danke Dir. Das läuft mit 4.1.19 wie geschnitten Brot!


    Update:


    Shit, zu früh gefreut.


    Mein Link auf ein externes Bild wird wie folgt angezeigt: [IMG:http://www.ExtDomain.de/ExtBild.jpg]

    Wenn ich in der Vorgängerversion auf den Link geklickt habe, dann wurde das Bild im Browser geöffnet und angezeigt.


    Mit der neuen Version wird folgender Link geöffnet (mit meiner Foren URL davor): http://meineDomain.de/%22http://www.ExtDomain.de/ExtBild.jpg%22


    Was nun?

    Einmal editiert, zuletzt von mv993 ()

  • Das sieht nach einem Fehler aus ;)

    Die Anzeige ist zwar die gewünschte, aber der Link wohl defekt.


    EDIT:


    Ist mit Version 1.1.0 pl 1 behoben.

  • Jaja, wenn die Nächte lang werden.


    Danke für das schnelle fixen.


    Jetzt scheint alles in Ordnung zu sein! :thumbup::thumbup::thumbup:

  • Servus,


    habe eben festgestellt, dass ich seit der Installation des Plugins "Image Hotlink Control" in folgendem Cronjob eine Fehlermeldung bekomme:



    Zusatzfrage: Warum gibt es den Cronjob zweimal in meiner Auflistung?


    Danke

    Michael

  • Das mit dem doppelten Cronjob liegt daran, dass ich nicht aufgepasst habe bei den Update-Instruktionen.


    Den Fehler wiederum behebe ich zeitnah.