Sortierung merken: Das Plugin fehlt mir soooo sehr...

  • In meinem WSC 3.0 hatte ich damals das Plugin Sortierung merken genutzt - ein kleines aber feines Plugin.


    Jetzt merke ich immer wieder in meiner 3.1 Installation, wie sehr mir dieses Plugin fehlt... Es nervt, jedes Mal die Plugin Liste aufs Neue sortieren zu müssen. Wenn die Standard Sortierung wenigstens Sinn machen würde. Zumindest mir erschließt sich kein Sinn dahinter...



    Im Thema WSC-Kompabilität unserer Erweiterungen (3.0 => 3.1) ist das Plugin aufgelistet unter

    Nahezu kompatibel (Anpassungen notwendig) / Portierung notwendig bzw. ausstehend


    Sind die Änderungen tatsächlich so gravierend? Oder reicht vielleicht nur ein Eingriff in eine XML Datei, um die Sache zum Laufen zu bringen?


    Könntet ihr vielleicht mal schauen, ob und in wie weit sich eine Portierung tatsächlich durchführen lässt? Ich bin mir sicher, dass ich nicht allein auf dieses kleine Plugin warte... ;)

    Ich brauche keine Signatur! :)

  • Ich hatte mal überlegt das in der DB zu tracken, via eigener tabelle und nem EL auf SortablePage...

    Wäre generell dann überall nutzbar (es würde für jede seite ein eintrag, bestehend aus userID, className, sortField und sortOrder angelegt).

    Die Frage ist ob das wirklich komplett für den user verständlich ist, wenn überall die zuletzt gewählte sortierung bestehen bleibt.

    Eventuell schreib ich das später einfach mal zusammen, ist in wenigen Minuten erledigt, dann kann man es mal testen.

    Wäre auch möglich das dann nur aufs ACP zu beschränken, und damit den normalen User nicht weiter zu belasten.

  • Das Plugin ist natürlich schnell angepasst. Allerdings überlege ich, das anders zu bauen, damit es eben nicht nur in der Paket-Liste läuft.

    Aber könntest du das Paket nicht vielleicht erst einmal nur anpassen und neue Features dann ggf. per Update nachreichen? ;)


    Wäre auch möglich das dann nur aufs ACP zu beschränken, und damit den normalen User nicht weiter zu belasten.

    So würde ich das bevorzugen. Die Benutzer sollen damit nichts zu tun haben. :)

    Ich brauche keine Signatur! :)

  • Meins wäre komplett unabhängig vom alten Plugin und daher kein Update, für letztes müsstest du dich mit Sascha einigen :P

  • Es wäre halt nur super, wenn das wieder für die Pluginliste kommen würde. Das wäre schon sehr hilfreich. ;)

    Ich brauche keine Signatur! :)

  • Hmm, klappt schonmal ziemlich gut :P

    Aktuell mal auf das ACP beschränkt, kann man aber theoretisch problemlos auch aufs Frontend ausweiten (eventuell optional, mal schauen).


    Ich hau gleich nen Beta Test raus, vorher muss Sascha nochmal drüber schauen^^