Update wird gekillt von js/SoftCreatR/FontAwesome.js

  • Hilfe, ich versuche seit Wochen mein Forum auf 3.0 upzudaten, und er bricht immer ab mit der Fehlermeldung :


    Danach ist alles hin, weder das alte noch das neue Forum gehen, Fehler über Fehler ...

    Also bleibt immer nur wieder das backup und die alte DB einspielen ... :(

  • Deinstallier das FontAwesome Plugin doch mal.... das neue wBB kommt doch mit FontAwesome daher...

  • Würde ich gerne, das "X" ist aber hell ...somit nicht löschbar ...

    noch dazu scheint es von maasdt ? ? zu sein ?

    Was geht denn da ab ?

    fehler.jpg

  • A package can't overwrite files from other packages. Only an update from the package which owns the file can do that.
    (Package 'de.softcreatr.wsc.fontAwesomeUtils' tries to overwrite file 'js/SoftCreatR/FontAwesome.js', which is owned by package 'de.softcreatr.wsc.fontAwesomeUtils')


    Die Fehlermeldung hat aber nichts mit dem Paket "Font Awesome Icon Util" aus dem WCF 2 zu tun.

  • Wie gesagt... Der eingangs aufgeführte Fehler gehört zum WSC und einem vollkommen anderen Plugin, nicht zum WCF.


    Durch diesen Tipp bekommst du lediglich die Möglichkeit, das Paket im WCF 2 zu deinstallieren.


    Der o.g. Fehler wiederum wird vom WSC 3 erzeugt. Ohne zu wissen, welche Erweiterungen da installiert sind, kann ich allerdings auch nicht viel dazu sagen.

  • Aber der oben genannte Fehler ist doch: A package can't overwrite files from other packages. Only an update from the package which owns the file can do that. (Package 'de.softcreatr.wsc.fontAwesomeUtils' tries to overwrite file 'js/SoftCreatR/FontAwesome.js', which is owned by package 'de.softcreatr.wsc.fontAwesomeUtils')

    Hört sich danach an als ob (ohne großartige Kenntnisse) in der Deinstallation nicht alle Tabellen aus der Datenbank gelöscht werden.

  • owned by package 'de.softcreatr.wsc.fontAwesomeUtils'


    Das sagt doch schon, dass es sich um ein WSC-Paket handelt und somit wie bereits erwähnt mit dem Paket Font Awesome Icon Util nichts zu tun hat. Die Dateien beider Pakete haben nicht einmal annähernd etwas miteinander zu tun.


    An dem Fehler A package can't overwrite files from other packages. Only an update from the package which owns the file can do that. (Package 'de.softcreatr.wsc.fontAwesomeUtils' tries to overwrite file 'js/SoftCreatR/FontAwesome.js', which is owned by package 'de.softcreatr.wsc.fontAwesomeUtils') kann ich auch nicht viel ändern, da das ein WSC-Problem ist.


    Es wäre erst einmal von Vorteil zu wissen, welche Pakete im WSC installiert sind.

  • Mhhh ... ich weiss nicht weiter ...

    Also hat woltlab ein paket das " js/SoftCreatR/FontAwesome.js" heisst und will es überschreiben ?

    auf dem server finde ich diesen Pfad überhaupt nicht ?!


    Und warum benennt woltlab ein Paket nach dir ?


    Edit ...unter wcf/js/SoftCreatR/ gibs das ...ich versuche das mal zu leeren und hau wieder das backup drauf ..


    Oben sieht man im screenshot was installiert ist ... multihunter und Impressum lösche ich aber immer vorher und dann den cache ...

    2 Mal editiert, zuletzt von higgy ()

  • verdammt ...vor dem update scheint das dort nicht zu existieren,

    d.h. beim update legt er es an, und meckert dann das es da ist ?!

  • Oben sieht man im screenshot was installiert ist ... multihunter und Impressum lösche ich aber immer vorher und dann den cache ...


    Der Screenshot stammt aber aus einem WCF 2 und nicht aus einem WSC 3, wo der Fehler entsteht.


    Das genannte Paket installiert sich jedenfalls nicht "einfach so" und ist auch kein Bestandteil der Original-Software von WoltLab. Im Normalfall wird diese Erweiterung in Kombination mit einer anderen Erweiterung (Lexikon, Shop, Martplatz, uvm. ) installiert. Heißt also, dass das Problem in Folge des Updates eines der installierten Viecode-Pakete entsteht. Und das eigentliche Problem ist, dass Viecode veraltete bzw. unterschiedliche Versionen dieses Zusatzpakets ausliefert.


    Allerdings bist du nicht der Erste, der genau dieses Problem hat. Siehe dazu auch Fehler beim Update --> WSC erkennt beim Update nicht ein schon Installiertes Paket - Erledigt - WoltLab®


    Zusammengefasst: Es ist reiner Zufall, dass einige Leute mit unserem Paket Probleme haben, zu updaten. Dass es genau dieses Paket ist, liegt vor allem daran, dass es zumindest im WSC 3.0 von sehr vielen Entwicklern als Abhängigkeit-, vor allem jedoch nicht unbedingt in derselben Version mitgeliefert wird.

  • mhhh, aber helfen tut mir das jetzt nicht,

    ich habe nun mal im / wcf/ js 2 Dateien umbenannt ..


    WCF.Icon.FontAwesome.min.js

    WCF.Icon.FontAwesome.js


    Auch witzig ... hier vor dem Update ...dann auf UPDATEN geklickt ....

    vorm_update.jpg


    Dann kommt nach 2 % ...


    IHRE SITZUNG ist abgelaufen ...und alles steht !

  • Das erinnert mich doch an Ein Loch ist im Eimer, oh Henry, wobei es jetzt heißen müsste, oh Higgy...


    Haare raufen, ja würde ich mir jetzt auch, mein Beileid.


    Herbert