Cannot Update - Packages Conflict

  • Hello,


    I am attempting to update from WSC 3.0.13 to 3.1.3 pl1. However, doing so shows a conflict message with the following:


    Code
    1. “Font Awesome” in version “1.0.0” prevents an update of “WoltLab Suite Core” to version “3.1.3 pl 1”.
    2. “SoftCreatR’s Packages (Release 3.0)” in version “1.0.0 RC 1” prevents an update of “WoltLab Suite Core” to version “3.1.3 pl 1”.
    3. “Invisible reCaptcha” in version “1.0.1” prevents an update of “WoltLab Suite Core” to version “3.1.3 pl 1”.


    I have the softcreatr.de vortex server in package server listing, but there doesn't seem to be a tornado server yet (at least, not not according to packages.softcreatr.de).


    When searching for updates, my WSC seems to believe that the font awesome utils et. al. are up to date, not offering an update for these packages. I know for a fact that there are new versions of these packages because I have several instances running 3.1.3 pl1 and they have newer versions of these packages installed.

    That said, I know the Invisible reCaptcha is built into the new system, so I could do away with that, but I'd like to be able to do in-place upgrades for these if at all possible. What would the best way to go about accomplishing this?


    Also, as a note to anyone who comes across this, I don't speak any German. Navigating this site is difficult enough, having to run back and forth between here and Google Translate :D


    Fox

  • Hi,


    the packages

    • SoftCreatR’s Packages (Release 3.0)
    • Invisible reCaptcha

    are safe to delete. And if there's no package requiring Font Awesome (which is indicated by the fact, that you can uninstall it), then also uninstall it. Alternatively, try updating it to 1.1.0 (Font Awesome 1.1.0 - SoftCreatR Media).


    Also, as a note to anyone who comes across this, I don't speak any German. Navigating this site is difficult enough, having to run back and forth between here and Google Translate :D


    Sorry about that. Our community was multilingual in the past, but especially the legal stuff is hard to maintain in multiple languages, so we just decided to get rid of every language but german.

  • Hello,


    Thanks for the help. Uninstalling those plugins (and hacking my theme to be "compatible") worked perfectly. I don't know if you have a closed or resolved tag, but this issue would definitely qualify.


    Fox