Nutzungsbedingungen 1.1.0 (WCF 2.1): Ablehnung umgeht Akzeptierung

  • Hallo,


    wenn ich die Nutzungsbedingungen ablehne werde ich zur Startseite geleitet. Wenn ich dann erneut versuche mich zu registrieren (selbe E-Mail-Adresse), dann erscheinen die Nutzungsbedingungen nicht mehr und ich kann mich ganz normal registrieren.


    Ich habe zwar bei "Aktion bei Ablehnung" "Nichts" eingestellt, jedoch sollte man doch trotzdem immer akzeptieren müssen um sich zu registrieren?


    Gruß,


    Afox

  • Ich werde aus dem Post leider noch nicht ganz schlau, da hier irgendwie Dinge vermischt werden. Die "Aktion bei Ablehnung" greift ja nur bei eingeloggten Mitgliedern. Gäste bekommen die Nutzungsbedingungen ausschließlich unmittelbar vor dem Registrierungsformular angezeigt und das auch nur so lange, bis sie diese akzeptiert haben und das jedoch ausschließlich, wenn die Option "Nutzungsbedingungen aktivieren" aktiviert ist. Die Akzeptanz wird bei Gästen über die gesamte Browser-Sitzung hinweg gespeichert.


    Fakt ist (oder sollte sein): So lange die Nutzungsbedingungen nicht akzeptiert werden, geht's nicht weiter.

  • bei mir ging es gerade weiter :/


    Kann es sein dass wenn der Nutzer schonmal registriert war und man ihn im ACP gelöscht hat, es immernoch irgendwo ein Überbleibsel in der DB zu diesem Nutzer geben könnte der einen weiter lässt? Das würde aber auch irgendwie nicht damit zusammenpassen, dass ich die Erklärung angezeigt bekam und jetzt ist sie weg nachdem ich einmal nicht akzeptiert habe.

  • ok, also ich kann es heute auch nicht mehr reproduzieren. komisch. naja erstmal danke, ich schreibe nochmal wenn es erneut auftritt.

  • Bist du denn sicher, dass du abgelehnt und nicht akzeptiert hast vor der Registrierung? Denn das wird nach dem Akzeptieren während der gesamten Browser-Session nicht mehr abgefragt.

  • eigentlich war ich mir sicher abgelehnt zu haben um es zu testen, weil ich zuvor noch nie abgelehnt hatte.

  • Ich hatte das auch mit den neuen Version getestet, bevor ich die in meinem Forum installiert habe und da funktionierte es wie es sollte. Bei Ablehnen konnte man nichts machen, außer die Bedingungen zu akzeptieren oder sich abzumelden, damit man als Gast lesen kann.

    Viele Grüße

    Luisa