Adventskalender kann nicht installiert werden

  • Hallo,


    wollte eben den Adventskalender installieren aber ich bekomme eine Fehlermeldung
    Ich kopiere es mal hier rein:



    Fatal error: A package can't overwrite files from other packages. Only an update from the package which owns the file can do that. (Package 'de.softcreatr.typhoon.optiontype.color' tries to overwrite file 'lib/system/option/ColorOptionType.class.php', which is owned by package 'de.wbb-elite.color.option')



    Information:


    id: c3ee1b53b893e09e3a0e1963f12b06fd1fd067c3
    error message: A package can't overwrite files from other packages. Only an update from the package which owns the file can do that. (Package 'de.softcreatr.typhoon.optiontype.color' tries to overwrite file 'lib/system/option/ColorOptionType.class.php', which is owned by package 'de.wbb-elite.color.option')
    error code: 0
    file: /var/www/vhosts/cats-castle.net/httpdocs/wcf/lib/system/package/FilesFileHandler.class.php (48)
    php version: 5.6.26
    wcf version: 2.1.11 (Typhoon)
    date: Mon, 17 Oct 2016 16:57:13 +0000
    request: /acp/index.php?install-package/&&

  • Das Problem ist, dass du bereits einen Color-Picker installiert hast (von WBB-Elite). Warum die ein eigenes Paket dafür veröffentlicht haben, ist mir schleierhaft. Ich werde mir das zeitnah anschauen.

  • Ich weiß leider nicht mehr, welches Plugin das war, bzw. mit welchem es zusammenhängt.
    Vermutlich die Benutzer-online-Markierung?

  • geh mal ins ACP und klick das Paket an, dann siehst du welche anderen pakete davon abhängig sind.

    Danke für den HInweis!


    Ok, nun weiß ich welches Paket es ist... es ist die Themen-Bewertung.




    Hoffe es gibt eine Lösung, denn den Adventskalender hätte ich sooo gerne :)

  • Ich bekomme beim Update folgendes:


    Zitat


    Fatal error: A package can't overwrite templates from other packages. Only an update from the package which owns the template can do that. (Package 'de.softcreatr.typhoon.adventcalendar' tries to overwrite template '__colorPicker', which is owned by package 'de.softcreatr.typhoon.optiontype.color')

  • lässt sich nicht updaten. Sie Fehler oben bzw. im woltlab Store.


    Ich denke, den vorherigen Kalender deinstallieren und den neuen nochmal installieren.

    schöne Grüße


    Tom

    Einmal editiert, zuletzt von tomerl ()

  • Bei mir geht es auch nicht


    template '__colorPicker'



    Ich denke, den vorherigen Kalender deinstallieren und den neuen nochmal installieren.

    Wenn man dann nicht alle Beiträge mühsam neu eingeben müßte ...

    Einmal editiert, zuletzt von Bernd Norden ()

  • Wenn man dann nicht alle Beiträge mühsam neu eingeben müßte ...


    Genau deswegen habe ich den Weg gewählt, den ich gewählt habe. Ihr müsst das Paket de.softcreatr.typhoon.optiontype.color deinstallieren. Der Kalender hat das bisher mitgeliefert bzw. erfordert. Durch die Inkompabilität zum o.g. Plugin Cyperghost war ich allerdings dazu gezwungen, entsprechende Änderungen durchzuführen, sodass der Kalender parallel betrieben werden kann.


    Allerdings befürchte ich, dass es hier zu anderen Problemen kommen könnte, wenn ich da jetzt so drüber nachdenke.


    EDIT:


    Ich überlege mir gerade noch etwas. Ein Update erscheint im Laufe des Tages.

  • Ja, ich weiß. Darauf waren die letzten beiden Sätze im letzten Post bezogen. Es nervt mich übrigens tierisch, dass ich jetzt wieder der Dumme bin, der die Fehler anderer (kommerzieller) Entwickler ausbaden darf. Ist nicht das erste Mal.

  • SoftCreatR schrieb:

    das Plugin Farbwähler Optionstyp (de.softcreatr.typhoon.optiontype.color) deinstallieren

    ...wenn man das oben genannte Plugin deinstalliert und dann den Adventkalender updatet bzw hochlädt funktioniert es.

  • ..wenn man das oben genannte Plugin deinstalliert und dann den Adventkalender updatet bzw hochlädt funktioniert es.

    Es lässt sich aber nicht deinstallieren! bzw. umgekehrt.


    Dein Farbwähler wird mit anderem Plugin auch benutzt. z.B. DKM Slider.

    schöne Grüße


    Tom

  • Naja, er muss nicht zwingend deinstalliert werden. Wichtig ist nur, dass sich der Kalender nun ohne dieses Paket installieren und verwenden lässt. Bedankt euch aber bitte nicht bei mir für diese Umstände.