Font Awesome Extension

  • Hallo,


    basierend auf auf diesem Wunsch haben wir die Erweiterung "Font Awesome Extension" für das WoltLab Community Framework 2.1 entwickelt.


    Dieses Plugin erweitert die im WoltLab Community Framework 2.1 enthaltene Font Awesome-Glyphensammlung um sämtliche fehlenden Glyphen seit Font Awesome v.4.4.0. Zusätzlich liefert diese Erweiterung auch fehlende CSS-Deklarationen im Legacy-Format (.icon-XXX), wodurch sämtliche der in der aktuellsten Font Awesome-Version enthaltenen Glyphen auch von Drittanbieter-Erweiterungen wie etwa Burning Board: Forum-Icons verwendet werden können. Parallel dazu stellen wir ein inoffizielles Update der Erweiterung Font Awesome Icon Util von Maasdt zur Verfügung, welches für einige andere Drittanbieter-Erweiterungen essentiell ist.


    Außerdem wurden unsere eigenen, auf Font Awesome basierenden Erweiterungen BBCode: fa und Redactor - Font Awesome aktualisiert, um auch hier die Möglichkeit der Nutzung aller aktuellen Glyphen zu ermöglichen.

  • Hallo,


    da es scheinbar zu unbedachten Problemen beim Wechsel vom WCF 2 zum WSC 3 gibt, möchte ich euch bitten, den Paket-Server https://packages.softcreatr.de/release/2.x-3.x/ im ACP hinzuzufügen und das Update danach erneut zu probieren (u.U. müsst ihr in der Paket-Liste im ACP danach noch einmal auf "Updates suchen" klicken). Wenn mein Plan aufgeht, sollte das Update damit reibungslos funktionieren.


    Bitte beachtet, dass die auf diesem Server befindlichen Pakete keinerlei Funktion mit sich bringen d.h. ihr solltet den Paket-Server nach dem erfolgreichen Update wieder entfernen. Beachtet zudem, dass dies AUSSCHLIEßLICH für den Wechsel vom WCF 2 zum WSC 3 gedacht ist und keinesfalls ohne diese Intention durchgeführt werden sollte!